AimBooster

AimBooster

To run AimBooster, you need to have a Flash player, and you need to allow this site to run Flash. You can do both by clicking on this button:

Get Adobe Flash player

If you get a popup saying "plugin blocked", you need to change your browser's settings, or try using a different browser. I'll work on rewriting the game to Javascript...